Mijn ervaringen met de producten van Mikrotik

Mikrotik met Ziggo WifiSpots

Door Dhr_Soulslayer op vrijdag 19 augustus 2016 11:21 - Reacties (5)
CategorieŽn: ICT, Mikrotik, Views: 3.510

Achtergrond:

Door persoonlijke interesse en werk ben ik veel in aanraking met Mikrotik producten. Mijn werk ervaring met Mikrotik producten begint bij de RB411U en de RB450 en loopt door de RB1100AHx2 en de Cloud Core Router series. Mijn persoonlijke mening over Mikrotik is dat het een mooi product is maar je moet wel redelijk goede kennis van netwerken hebben om het optimaal te laten werken. Mijn eigen thuis netwerk draait volledig op Mikrotik gewoon omdat het kan en het mij nog meer kennis opleverd over de producten en netwerken. Genoeg daarover nu op naar het leuke gedeelte.

Mikrotik en Ziggo Hotspots:
De draadloze interface binnen een Mikrotik kan gebruikt worden als Accespoint maar ook als draadloze client. Hiermee is het mogelijk om verbinding te maken met een willekeurige netwerk. Leuk om in te stellen als backup verbinding van bijvoorbeeld de buren(Als je netjes de sleutel hebt gekregen en het netjes gevraagd hebt of het mag). Echter kan je ook verbinden met een Wifi Hotspot netwerk. Ik heb het getest met een hotspot van Ziggo omdat die veel in mijn buurt actief zijn. Mocht dus mijn modem eruit vliegen kan ik nog steeds internetten en hoef ik geen complexe oplossingen te bedenken om toch internet te hebben.

Mijn opzetje van mijn netwerk ziet er zo uit:
MT_Ziggo

Zoals te zien is staat mijn Ziggo modem in DMZ modus richting mijn RB2011. (Bedankt ziggo voor het niet beschikbaar maken van de bridge modus bij een ZZP abo maar wel bij een consumentenlijn of groot zakelijk 8)7 |:( ) De default route op mijn RB2011 staat naar het modem met een distance van 1. Hierdoor heeft deze route de voorkeur. Zal deze wegvallen dan komt de volgende default route in beeld namelijk die naar mijn wifi interface. Deze is verbonden met de ziggo hotspot en zal daar dan al het internet overheen routeren.

De juiste configuratie voor het laten verbinden van je MT met het Ziggo netwerk is alsvolgt:

name="Ziggo" mode=dynamic-keys authentication-types=wpa-eap,wpa2-eap
unicast-ciphers=tkip,aes-ccm group-ciphers=tkip,aes-ccm wpa-pre-shared-key=""
wpa2-pre-shared-key="" supplicant-identity="WIFISPOT_USERNAME" eap-methods=eap-ttls-mschapv2
tls-mode=dont-verify-certificate tls-certificate=none mschapv2-username="WIFISPOTS_USERNAME"
mschapv2-password="WIFISPOT_PASSWORD" static-algo-0=none static-key-0="" static-algo-1=none
static-key-1="" static-algo-2=none static-key-2="" static-algo-3=none static-key-3=""
static-transmit-key=key-0 static-sta-private-algo=none static-sta-private-key=""
radius-mac-authentication=no radius-mac-accounting=no radius-eap-accounting=yes
interim-update=0s radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username-and-password
radius-mac-caching=disabled group-key-update=5m management-protection=disabled

Dit dien je in te voren via de CLI op het pad /interface/wireless

LETOP: Je dient te beschikken over een Ziggo Hotspots login.

Mocht je er niet meteen uitkomen zet dan debug logging aan en kijk goed in de logs. Daarstaat vaak waar en/of waarom het fout gaat.